การใช้งาน TURBO C++

การติดตั้ง TURBO C++
          ขั้นแรกหากเป็นการติดตั้งครั้งแรกให้คุณ Download File TC3.EXE ไป แล้ว Copy ไปเก็บไว้ที่ DRIVE C นอกสุดจากนั้นที่ C:\ พิมพ์ TC จากนั้นเครื่องจะเริ่มทำการติดตั้ง TURBO C++ ลงใน DIRCTORY C:\Langs\Tc3\ ให้คุณโดยอัตโนมัติ หรือเรียกผ่าน Windows Explorer และกด upzip ดังรูป


การใช้งาน TURBO C++
          เมื่อเข้าสู่โปรแกรม TURBO C++ โดยไปที่  DIRECTORY C:\Langs\Tc3\Bin\ เรียก RUN FILE ชื่อ TC.EXE โดยพิมพ์ TC แล้วท่านจะเห็นหน้าตาของโปรแกรมเป็นดังรูป


          การใช้เมนูด้านบนสามารถทำได้โดบการกด F10 หรือ คลิกส์ Mouse ไปที่เมนูซึ่งรายละเอียดของ Menu ใน TurboC++ อิดิเตอร์ มีดังต่อไปนี้
Menu File

1. New

คำสั่งนี้จะเป็นการสร้างไฟล์ภาษา C, CPP ตัวใหม่ขึ้นมา

2. Open...

คำสั่งนี้จะเป็นการเปิดไฟล์ภาษา C, CPP ที่เคยจัดเก็บมาไว้เพื่อนำมาแก้ไข

3. Save

คำสั่งนี้จะเป็นการบันทึกไฟล์ภาษา C, CPP ลงบน DISK ตามชื่อที่เคยกำหนด

4. Save as...

คำสั่งนี้จะเป็นการบันทึกไฟล์ภาษา C, CPP ลงบน DISK โดยเปลี่ยนชื่อใหม่

5. Save all

คำสั่งนี้จะเป็นการบันทึกไฟล์ภาษา C, CPP ทุก Windows ที่เปิดอยู่ ลงบน DISK

6. Change dir...

คำสั่งนี้จะเป็นการเปลี่ยน DIRECTORY หลักที่ทำการ SAVE

7. Print

คำสั่งพิมพ์ไฟล์ภาษา C, CPP ทำทำออกเครื่องพิมพ์

8. DOS Shell

คำสั่งออกไป DOS ชั่วคราว สามารถกลับสู่ TURBO C++ โดยการพิมพ์ EXIT

9. Quit

คำสั่งออกจากโปรแกรม


Menu Edit

1. Undo

คำสั่งยกเลิกการกระทำครั้งหลังสุด

2. Redo

คำสั่งทำการกระทำสิ่งที่ยกเลิกการกระทำครั้งหลังสุด

3. Cut

คำสั่งตัดส่วนของข้อความที่ทำ Height Light ไว้ ไปเก็บใน clipboard

4. Copy

คำสั่งคัดลอกส่วนของข้อความที่ทำ Height Light ไว้ ไปเก็บใน clipboard

5. Paste

คำสั่งคัดวางส่วนของข้อความที่เก็บใน clipboard ลงไปที่ตำแหน่งของ Curser

6. Clear

คำสั่งลบส่วนของข้อความที่ทำ Height Light ไว้

7. Copy example

 

8. Show clipboard

คำสั่งแสดงข้อมูลที่ถูกเก็บอยู่ใน clipboard


Menu Search

1. Find...

คำสั่งใช้ค้นหาคำบางคำในเอกสารภาษา C,C++

2. Replace...

คำสั่งใช้ค้นหาคำบางคำในเอกสารภาษา C,C++ และแทนที่คำ ๆ นั้นด้วยคำที่กำหนด

3. Search again

คำสั่งใช้ค้นหาคำบางคำในเอกสารภาษา C,C++ ต่อจากบรรทัดที่ค้นเจอ

4. Go to line number...

คำสั่งกระโดดไปยังบรรทัดที่กำหนด

5. Previous error

 

6. Next error

 

7. Locate function...

 


Menu Run

1. Run

คำสั่งทำการแปลง ไฟล์ C, CPP เป็น OBJ แล้วสร้างเป็น EXE เลย

2. Program reset

คำสั่งให้เครื่องกลับสู่สภาวะปกติก่อนที่จะ RUN โปรแกรม

3. Go to cursor

คำสั่งกระโดดไปบรรทัดที่ CURSOR อยู่

4. Trace into

RUN ไฟล์ C, CPP ทีละคำสั่ง

5. Step over

RUN ไฟล์ C, CPP ทีละชุดคำสั่ง

6. Arguments...

 


Menu Compile

1. Compile

คำสั่งทำการแปลง ไฟล์ C, CPP เป็น OBJ

2. Make

คำสั่งทำการแปลง ไฟล์ OBJ เป็น EXE

3. Link

คำสั่งทำการแปลง ไฟล์ OBJ เป็น EXE หรือ COM

4. Build all

คำสั่งทำทั้งหมด

5. Information...

แสดงรายละเอียดของไฟล์ในการแปลง

6. Remove message

คำสั่งลบข้อความที่อยู่ในหน้าต่าง Message


Menu Debug

1. Inspect...

ตัวตรวจสอบ

2. Evaluate/modify...

หาค่าประเมินค่า/เปลี่ยนแปลง

3. Call stack...

คำสั่ง ทดลองเรียกดูค่าใน STACK

4. Watches

เฝ้ามอง

5. Toggle breakpoint

คำสั่งสลับการทำงานไปที่ Break Point ที่ละช่วง

6. Breakpoint...

คำสั่งในการกำหนดจุดให้โปรแกรมหยุดการทำงานชั่วคราวเพื่อตรวจสอบโปรแกรม


Menu Project

1. Open project...

เปิดโปรเจ็คไฟล์นามสกุล PRJ เพื่อเชื่องไฟล์ภาษา C, CPP ที่มากกว่า 1 ไฟล์

2. Close project

ปิดโปรเจ็คไฟล์นามสกุล PRJ

3. Add item...

คำสั่งเพิ่มข้อมูลใน Project File

4. Delete item

คำสั่งลบข้อมูลใน Project File

5. Local options...

คำสั่งปรับเปลี่ยนที่อยู่ของ Local

6. Include files...

คำสั่งในการสร้าง Include files


Menu Options

1. Application...

คำสั่งปรับแต่งคุณสมบัติทั่วไปของตัวโปรแกรมที่จะสร้าง

2. Compiler

คำสั่งปรับแต่งคุณสมบัติทั่วไปของตัวแปรภาษาในการสร้าง OBJ Code

3. Transfer...

คำสั่งปรับแต่งคุณสมบัติในการ Tranfer Code ไปใช้ในเครื่องแบบต่าง ๆ

4. Make...

คำสั่งปรับแต่งคุณสมบัติทั่วไปของตัวแปรภาษาในการสร้าง Exe Code

5. Linker

คำสั่งปรับแต่งคุณสมบัติทั่วไปของตัวแปรภาษาในการสร้าง Exe Code , Com Code

6. Librariant...

คำสั่งตั้งค่า Library ต่าง ๆ

7. Debugger...

คำสั่งตั้งค่าต่าง ๆ ในการตรวจสอบโปรแกรม

8. Directories...

คำสั่งเปลี่ยนแปลงแก้ไข Directory ให้ทำงานได้ถูกต้อง

9. Enviroment

 

10. Save...

คำสั่งบันทึกคุณสมบัติที่ได้ปรับแต่งไป


Menu Window

1. Size/Move

คำสั่งกำหนดขนาดของ Window และการเคลื่อนย้ายตำแหน่งของ Window

2. Zoom

คำสั่งขยายขนาดของ Window เต็มจอ

3. Tile

คำสั่งแสดง windows แบบ Title (ไม่ซ้อนกัน)

4. Cascade

คำสั่งแสดง windows แบบ Cascade (ซ้อนกันเป็นชั้น)

5. Next

คำสั่งย้ายไป Windows ถัดไป

6. Close

คำสั่งปิด Windows

7. Close all

คำสั่งปิดหน้าต่าง Windows ทุกตัวที่เปิดอยู่

8. Message

คำสั่งซ่อนและแสดงหน้าต่าง Message (ตัวรายงานผล)

9. Output

คำสั่งแสดงผล Windows หน้าจอ Output

10. Watch

คำสั่งซ่อนและแสดงหน้าต่าง Wath (ใช้สำหรับดูค่าของตัวแปรต่าง ๆ ขณะ Run โปรแกรม)

11. User screen

คำสั่งแสดงหน้าจอผู้ใช้

12. Register

คำสั่งแสดงหน้าต่า Register

13. Project

คำสั่งควบคุมหน้าต่าง Project

14. Project note

คำสั่งควบคุมหน้าต่าง Project note

15. List all...

แสดงรายชื่อ Windows ที่เปิดอยู่ทั้งหมด


Menu Help

1. Contents

ความหมาย เนื้อหา

2. Index

ดัชนีการของความช่วยเหลือ

3. Topic search

ค้นหาคำสั่ง

4. Previous topic

เปลี่ยนหัวเรื่องการช่วยเหลือ

5. Help on Help

ตัวแนะนำวิธีใช้ Help

6. About

คำสั่งแสดงชื่อของโปรแกรม C++ เลข Version และผู้ผลิต Borland